Konfigurasi RIP pada Router Cisco

cisco-logo

Introduction to Routing Information Protocol (RIP)

Selain menggunakan static routing, untuk menghubungkan beberapa jaringan juga dapat digunakan teknik dynamic routing. Pada saat akan menggunakan dynamic routing, Administrastor jaringan tidak perlu menyusun tabel routing secara manual. Router akan dapat mengetahui network-network yang ada, dan menyusun sendiri tabel routingnya.

Untuk menyusun tabel routing sendiri, maka router harus menjalankan routing protocol. Routing protocol ini yang akan digunakan untuk bertukar informasi dengan router-router lain yang ada dalam jaringan tersebut. Informasi yang dipertukarkan dapat berupa network address, tipe jaringan maupun cost yang diperlukan untuk menuju network tersebut. Hasil pengolahan dari pertukaran informasi tersebut akan menjadi tabel routing.

Salah satu routing protocol yang mudah untuk diimplementasikan adalah Routing Information Protocol (RIP). RIP merupakan routing protocol dengan kategori Distance Vector (arah dan jarak). Routing protocol ini tidak mengurasi resource router dan mudah dikonfigurasikan dan mudah melakukan troubleshoot.

RIP memiliki kekurangan antara lain waktu respon yang lebih lambat, sehingga tidak cocok untuk jaringan dengan skala besar. Router yang menjalankan RIP juga tidak memiliki gambaran topologi yang jelas, sehingga besar kemungkinan terjadi routing loop. Sebuah router RIP hanya mengandalkan router tetangga untuk mengetahui keberadaan remote network.

RIP terdiri dari beberapa versi, yaitu RIPv1 yang hanya bisa bekerja pada jaringan dengan pengalamatan classful, RIPv2 yang merupakan penyempurnaan RIPv1 yang bisa bekerja pada jaringan classless, dan RIPng untuk jaringan dengan pengalamatan IPv6.

 

 

Basic Configuration

Untuk mengkonfigurasikan RIP pada sebuah router diperlukan dua langkah yaitu :
•    Mengaktifkan routing protocol RIP melalui global configuration mode
•    Meng-advertise network yang ingin diperkenalkan melalui RIP.

q1_basic_rip

Untuk contoh topologi di atas, konfigurasi yang harus dilakukan pada Router R1 adalah sebagai berikut.

R1#configure terminal
R1(config)#router rip
R1(config-router)#network 192.168.1.0
R1(config-router)#network 10.0.0.0

 

 

Sedangkan pada Router R2, konfigurasi RIP yang perlu dilakukan adalah sebagai berikut.

R2#configure terminal
R2(config)#router rip
R2(config-router)#network 192.168.2.0
R2(config-router)#network 10.0.0.0

 

Jika kedua router telah mencapai kondisi convergence, maka baik entry directly connected network maupun remote network akan terlihat pada tabel routing. Remote network yang diketahui melalui RIP akan berupa entry routing dengan codes R, seperti terlihat pada tabel routing pada R1 maupun R2 berikut ini.

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS 
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/0
R    192.168.2.0/24 [120/1] via 10.10.10.2, 00:00:15, FastEthernet0/1

 

R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS 
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/1
R    192.168.1.0/24 [120/1] via 10.10.10.1, 00:00:16, FastEthernet0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0

 

 

RIPv1 sebagai Classful Routing Protocol

RIPv1 merupakan classful routing protocol, sehingga tidak dapat digunakan pada jaringan classless. Apalagi pada jaringan yang menerapkan subnetmask yang berbeda-beda (Variable Length Subnet Mask) seperti pada gambar berikut ini.

q2_rip_classfull

Karena tidak bisa membedakan subnetmask, maka Router R1 yang menjalankan RIPv1 tidak dapat membedakan network 172.16.20.0/24 milik R2 dengan dengan network 172.16.30.0/24 milik R3. Router R1 akan menganggap kedua network tersebut sebagai network 172.16.0.0/16, seperti terlihat berikut ini.

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/30 is subnetted, 3 subnets
C       10.10.10.0 is directly connected, FastEthernet0/1
C       10.10.10.4 is directly connected, FastEthernet1/0
R       10.10.10.8 [120/1] via 10.10.10.2, 00:00:08, FastEthernet0/1
         [120/1] via 10.10.10.5, 00:00:18, FastEthernet1/0
R    172.16.0.0/16 [120/1] via 10.10.10.2, 00:00:08, FastEthernet0/1
         [120/1] via 10.10.10.5, 00:00:18, FastEthernet1/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0

 

Pada saat R1 akan melakukan ping ke network 172.16.20.0/24 maupun network 172.16.30.0/24 akan terlihat seperti berikut ini.

R1#ping 172.16.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:
U!.!U
Success rate is 40 percent (2/5), round-trip min/avg/max = 2/6/4 ms

 

R1#ping 172.16.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.1, timeout is 2 seconds:
U!.!U
Success rate is 40 percent (2/5), round-trip min/avg/max = 3/8/5 ms

 

RIPv2 sebagai Classless Routing Protocol

Untuk menerapkan RIPv2, maka perlu dinon-aktifkan juga fitur auto summary yang secara default digunakan oleh RIPv2. Perintah yang dapat digunakan adalah sebagai berikut.

R1#configure terminal
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary

 

R2#configure terminal
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary

 

R3#configure terminal
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary

Hasil akhir dari tabel routing pada Router R1 setelah menggunakan RIPv2 dapat dilihat seperti berikut ini.

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/30 is subnetted, 3 subnets
C       10.10.10.0 is directly connected, FastEthernet0/1
C       10.10.10.4 is directly connected, FastEthernet1/0
R       10.10.10.8 [120/1] via 10.10.10.2, 00:00:10, FastEthernet0/1
                                  [120/1] via 10.10.10.5, 00:00:02, FastEthernet1/0
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
R       172.16.0.0/16 [120/1] via 10.10.10.2, 00:01:36, FastEthernet0/1
                                          [120/1] via 10.10.10.5, 00:01:49, FastEthernet1/0
R       172.16.20.0/24 [120/1] via 10.10.10.2, 00:00:10, FastEthernet0/1
R       172.16.30.0/24 [120/1] via 10.10.10.5, 00:00:02, FastEthernet1/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0

 

Pengujian ping dari Router R1 kepada network 172.16.20.0/24 dan 172.16.30.0/24 akan terlihat seperti berikut ini.

R1#ping 172.16.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/14 ms

 

R1#ping 172.16.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/7 ms

 

Untuk melihat sebuah router menggunakan RIPv1 atau RIPv2, maupun aktif tidaknya auto summary, maka dapat dilihat pada file konfigurasi yang sedang berjalan, seperti uraian berikut ini.

R1#show running-config
Building configuration...

Current configuration : 912 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname R1
!
enable secret 5 $1$mERr$4vfr73Wxo/Khm7H07xY6D.
enable password 7 08701E1D5D4C53
!
!
ip name-server 0.0.0.0
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.10.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.10.10.6 255.255.255.252
duplex auto
speed auto
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
ip classless
!
line con 0
password 7 0822455D0A16
login
line vty 0 4

 

Metric

RIP menggunakan hop count (jumlah lompatan) sebagai metric. Jumlah lompatan (hop) tersebut akan digunakan router RIP untuk menentukan jalur mana yang lebih baik (best path) untuk menuju sebuah remote network. Path atau jalur dengan nilai hop count terkecil yang akan dimasukkan ke dalam tabel routing.

q3_rip_metric1

Bagi Router R1, untuk menuju network 172.16.20.0/24 dapat melalui R2 dengan hop count 1 dan dapat juga melalui R3 dengan hop count 2.  Router R1 akan memilih jalur (path) yang melalui R2 untuk dimasukkan ke dalam tabel routing dan path inilah yang akan digunakan untuk mengirimkan packet ke network 172.16.20.0/24. Path tersebut dapat dilihat pada tabel routing berikut ini.

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

Gateway of last resort is not set

10.0.0.0/30 is subnetted, 3 subnets
C       10.10.10.0 is directly connected, FastEthernet0/1
C       10.10.10.4 is directly connected, FastEthernet1/0
R       10.10.10.8 [120/1] via 10.10.10.2, 00:00:16, FastEthernet0/1
                                  [120/1] via 10.10.10.5, 00:00:03, FastEthernet1/0
          172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
R       172.16.0.0/16 is possibly down, routing via 10.10.10.2, Fast0/1
                                          is possibly down, routing via 10.10.10.5, Fast1/0
R       172.16.20.0/24 [120/1] via 10.10.10.2, 00:00:16, FastEthernet0/1
R       172.16.30.0/24 [120/1] via 10.10.10.5, 00:00:03, FastEthernet1/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0

 

Jika ternyata link antara Router R1 dan R2 down, maka R1 baru akan menggunakan path yang melalui R3 untuk menuju network 172.16.20.0/24, tentunya dengan hop count yang lebih besar, yaitu 2.

q4_rip_metric2

Sehingga path melalui R3 juga yang akan terlihat pada tabel routing R1, seperti berikut ini.

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/30 is subnetted, 2 subnets
C       10.10.10.4 is directly connected, FastEthernet1/0
R       10.10.10.8 [120/1] via 10.10.10.5, 00:00:03, FastEthernet1/0
          172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
R       172.16.0.0/16 is possibly down, routing via 10.10.10.5, Fast1/0
R       172.16.20.0/24 [120/2] via 10.10.10.5, 00:00:03, FastEthernet1/0
R       172.16.30.0/24 [120/1] via 10.10.10.5, 00:00:03, FastEthernet1/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0

 

Perintah lain yang dapat digunakan untuk melihat beberapa path yang diketahui oleh sebuah router adalah sebagai berikut.

R1#show ip rip database
10.10.10.4/30     directly connected, FastEthernet1/0
10.10.10.8/30
             [1] via 10.10.10.5, 00:00:14, FastEthernet1/0
172.16.20.0/24
            [2] via 10.10.10.5, 00:00:14, FastEthernet1/0
172.16.30.0/24
            [1] via 10.10.10.5, 00:00:14, FastEthernet1/0
192.168.1.0/24    directly connected, FastEthernet0/0

 

 

— end of chapter —

Leave a Reply

Your email address will not be published. Required fields are marked *