Konfigurasi Virtual Routing and Forwarding (VRF) pada Router MikroTik

Secara umum, router tidak akan dapat digunakan untuk menghubungkan jaringan yang sama, karena memang perangkat ini didisain untuk menghubungkan jaringan yang berbeda-beda. Namun, dengan Virtual Routing and Fowarding (VRF), maka router pun dapat digunakan untuk menghubungkan atau mengelola jaringan yang menggunakan pengalamatan yang sama.Virtual Routing and Forwarding bekerja dengan membuat beberapa tabel routing pada sebuah router. Jika umumnya kita hanya mengenal satu tabel routing, maka dengan VRF, kita akan dapat membuat beberapa tabel routing lagi. Beberapa tabel routing inilah yang bisa membuat sebuah router mengelola beberapa jaringan yang sama tadi.

Dari gambar di atas, terlihat ada 2 (dua) unit komputer yang memiliki IP Address yang sama, yaitu 192.168.1.2. Komputer yang pertama terhubung pada interface ether2, sedangkan komputer yang kedua terhubung pada interface ether3.

 

Konfigurasi Dasar

Sebelum melakukan konfigruasi Virtual Routing Forwarder, maka konfigurasi dasar yang perlu dilakukan pada Router GW adalah konfigurasi dasar seperti pada umumnya. Konfigurasi ini meliputi konfigurasi IP Address pada semua interface, konfigurasi default route, konfigurasi DNS Server dan konfigurasi Firewall Masquerade. Adapun perintah yang dapat digunakan untuk melakukan konfigurasi dasar tersebut adalah sebagai berikut.

/ip address add address=11.1.1.2/30 interface=ether1
/ip address add address=192.168.1.1/24 interface=ether2
/ip address add address=192.168.1.1/24 interface=ether3
/ip route add gateway=11.1.1.1
/ip dns set servers=1.1.1.254,2.2.2.254 allow-remote-request=yes
/ip firewall add nat chain=srcnat out-interface=ether1 action=masquerade

Setelah dilakukan konfigurasi dasar, harus dipastikan bahwa Router GW sudah terhubung ke Internet dengan menggunakan perintah berikut ini.

/ping www.google.com
SEQ HOST SIZE TTL TIME STATUS 
0 118.98.106.178 56 58 18ms
1 118.98.106.178 56 58 18ms
2 118.98.106.178 56 58 20ms
3 118.98.106.178 56 58 16ms
sent=4 received=4 packet-loss=0% min-rtt=16ms avg-rtt=18ms max-rtt=20ms

 

Konfigurasi VFR

Secara default, tabel routing di router MikroTik hanya ada 1 (satu) tabel, dan tabel ini dinamakan tabel main. Untuk melihat tabel routing ini dapat menggunakan perintah seperti berikut ini.

[admin@GW] > ip route print detail
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 0 A S dst-address=0.0.0.0/0 gateway=11.1.1.1 gateway-status=11.1.1.1 reachable via ether1 
       distance=1 scope=30 target-scope=10 

 1 ADC dst-address=11.1.1.0/30 pref-src=11.1.1.2 gateway=ether1 gateway-status=ether1 
       reachable distance=0 scope=10 

 2 ADC dst-address=192.168.1.0/24 pref-src=192.168.1.1 gateway=ether2,ether3 
       gateway-status=ether2 reachable,ether3 reachable distance=0 scope=10 

Dengan menggunakan WinBox, menu yang dapat digunakan adalah IP > Routes, seperti terlihat pada gambar berikut ini. Perhatikanlah bahwa tabel routing yang ditampilkan adalah tabel routing main.


Konfigurasi VRF dilakukan dengan menambahkan tabel routing. Sebagai contoh, untuk jaringan yang berada pada interface ether2 akan menggunakan tabel routing vrf-satu. Untuk membuat tabel routing tambahan ini, dapat digunakan perintah seperti berikut ini.

/ip route vrf add routing-mark=vrf-satu interfaces=ether2

 

Untuk jaringan yang berada pada interface ether3, tabel routing yang akan digunakan adalah tabel routing dengan nama vrf-dua. Adapun perintah untuk membuat tabel routing vfr-dua adalah sebagai berikut.

/ip route vrf add routing-mark=vrf-dua interfaces=ether3

 

Dengan menggunkan WinBox, menu yang dapat digunakan adalah IP > Routes > tab VRF > tombol Add, seperti pada gambar berikut ini.

Sampai pada konfigurasi ini, Router MikroTik kita sudah memiliki 3 (tiga) tabel routing, masing-masing adalah tabel routing main, tabel routing vrf-satu dan tabel routing vrf-dua.

 

Jika diperhatikan, kedua tabel routing tambahan tidak memiliki entry default route untuk menuju Internet. Entry default route yang harus menggunakan IP Address 1.1.1.1 sebagai parameter gateway sudah ada pada tabel routing utama atau tabel routing main. Ini akan membuat client yang terhubung di interface ether2 tidak akan dapat menuju Internet, begitu pula dengan client yang ada di interface ether3.

Parameter gateway yang ada pada tabel routing utama dapat digunakan juga sebagai parameter gateway pada kedua tabel routing tambahan. Teknik ini dikenal dengan teknik route leaking. Adapun perintah yang dapat digunakan untuk menggunakan entry default route pada tabel routing main tersebut adalah sebagai berikut.

/ip route add routing-mark=vrf-satu dst-address=0.0.0.0/0 gateway=11.1.1.1@main

/ip route add routing-mark=vrf-dua dst-address=0.0.0.0/0 gateway=11.1.1.1@main

 

Saat traffic atau packet yang dikelola oleh tabel routing vfr-satu keluar menuju Internet, maka harus dipastikan bahwa packet tersebut harus kembali dikelola oleh tabel routing vrf-satu. Ini harus diperhatikan karena pada saat ini, router GW sudah memiliki 3 (tiga) tabel routing. Demikian pula packet yang keluar dari tabel routing vfr-dua, harus dipastikan akan kembali dikelola oleh tabel routing tersebut. Ilustrasinya dapat dilihat pada gambat berikut ini.


Adapun perintah yang dapat digunakan untuk memastikan packet yang keluar menuju Internet akan kembali dikelola oleh tabel routing pengirimnya, perintah yang dapat digunakan adalah sebagai berikut.

/ip firewall mangle add chain=prerouting in-interface=ether2 action=mark-connection new-connection-mark=vrf-satu-conn passthrough=yes
/ip firewall mangle add chain=prerouting in-interface=ether1 connection-mark=vrf-satu-conn action=mark-routing new-routing-mark=vrf-satu passthrough=yes

/ip firewall mangle add chain=prerouting in-interface=ether3 action=mark-connection new-connection-mark=vrf-dua-conn passthrough=yes
/ip firewall mangle add chain=prerouting in-interface=ether1 connection-mark=vrf-dua-conn action=mark-routing new-routing-mark=vrf-dua passthrough=yes

 
Setelah konfigurasi di atas selesai dilakukan, seharusnya kedua komputer sudah dapat terhubung ke Internet. Anda sebenarnya juga bisa menambahkan DHCP Server dengan alokasi IP Address yang sama, baik pada interface ether2 maupun interface ether3

Acuan : http://www.mikrotik.co.id/artikel_lihat.php?id=211

 

— end of chapter —

Leave a Reply

Your email address will not be published. Required fields are marked *